apache not starting in devstack (Address already in use)

By | 12th February 2015

One of the issues noticed while running devstack in my virtual machine.

It was not able to start the apache service it was failing. The below error reflected that there was already a process running on the same port.

>> error
(98)Address already in use: AH00072: make_sock: could not bind to address [::]:80
(98)Address already in use: AH00072: make_sock: could not bind to address 0.0.0.0:80

>>

Fixing it :

Kill the process since it is blocking from apache to start.
Use sudo otherwise the process id will not be listed.

rn@rn-virtual-machine:~$ sudo netstat -ltnp | grep ‘:80’
tcp 0 0 127.0.0.1:80 0.0.0.0:* LISTEN 3128/aolserver4-nsd
rn@rn-virtual-machine:~$

rn@rn-virtual-machine:~$ netstat -ltnp | grep ‘:80’
(Not all processes could be identified, non-owned process info
will not be shown, you would have to be root to see it all.)
tcp 0 0 127.0.0.1:80 0.0.0.0:* LISTEN –
rn@rn-virtual-machine:~$

If required the packages can be removed using dpkg -r

rn@rn-virtual-machine:~$ dpkg –list | grep -i aol
ii aolserver4-core 4.5.1-16 amd64 AOL web server version 4 – core libraries
ii aolserver4-daemon 4.5.1-16 amd64 AOL web server version 4 – program files
ii aolserver4-doc 4.5.1-16 all AOL web server version 4 – documentation
ii aolserver4-nssha1 0.1-3build1 amd64 AOLserver4 module: performs SHA1 hashes Provides a Tcl

(Running on Ubuntu 14.04)

Leave a Reply

Your email address will not be published. Required fields are marked *